My phone does not have NFC. What can I do?

To be able to use the femSense patch, an NFC capable
smartphone is required. Without the femSense patch, you can
use the app as a period diary.

Updated on: 31/05/2023

Was this article helpful?

Share your feedback

Cancel

Thank you!